Lokale Testinstallation von WordPress 3.0 per Xampp

Jungfräuliches Standardtemplate
Geschätzte Lesezeit: 2 Minuten

Einerseits hat mich die Neugier übermannt, wie die Version von WordPress 3.0 funktioniert, andererseits bin ich doch ein wenig vorsichtig, was das Update meines Blogs betrifft. Ich habe gerade meinen Blog so eingerichtet, dass alles funktioniert und aussieht, wie ich ihn mir vorgestellt habe. Ich möchte vermeiden, dass er durch das Update zerschossen wird.

Daher habe ich mich erst einmal für eine lokale Installation per Xampp entschieden. Darin möchte ich testen, ob mein Theme und sämtliche Plugins mit der Version 3.0 kompatibel sind.

Die Installation von Xampp ist hier wunderbar beschrieben und da die Dateien lokal gespeichert werden, besteht für meinen aktuellen Blog auch keine Gefahr. Nun werde ich Schritt für Schritt versuchen, sämtliche Features meines Blogs auf dem Lokalserver zu übernehmen und darüber berichten, was funktioniert hat und was nicht.

Wie sieht ein Template mit meinen Blog-Inhalten aus?

Jungfräuliches StandardtemplateSo sieht fürs Erste mein total unbearbeiteter Blog aus:

Nun wollte ich aber mal wissen, wie mein Blog in dem Standardtheme mit meinen Beiträgen wirkt.

Daher wählte ich unter Werkzeuge >> Daten importieren, um die exportierten Sicherungsdateien aus meinem Blog in diese lokale Installation zu übertragen. Dazu muss allerdings erst noch das Plugin Importer installiert werden.

Meines Wissens war dieses damals bei dem Datenimport von meiner Flatpress-Version auf die gehostete Version nicht erforderlich. Dafür ist es wohl aber nun möglich, auch von anderen diversen Blogdiensten die Daten zu importieren.

Nun muss es nur noch aktiviert werden und los geht’s.

Blogseite nach Import im Standardtheme Twenty TenNa wunderbar, das hat ja schon mal geklappt. Alle Beiträge, Kommentare, Kategorien, Bilder usw. wurden übernommen.

Mit dem neuen Standardtheme Twenty Ten habe ich dann ein wenig herum experimentiert und auch wenn es mit etlichen individuellen Gestaltungsmöglichkeiten aufwarten kann, kommt es für mich nicht in Frage, da mir Smoky derzeit für meinen Blog einfach am besten gefällt und ich es mittlerweile bis ins Detail angepasst habe.

Fehlermeldung bei Installation des Themes "Smoky"

Dann kam der große Augenblick – Smoky-Theme installiert und prompt kam eine Fehlermeldung:

Nur was soll mir die Stelle in der index.php nun sagen?

Erste Schlussfolgerung

Okay, also mein aktuelles Theme mag WordPress 3.0 nicht. Testweise habe ich mein Vorgänger-Theme palmixio installiert, mit diesem gab es wiederum keinerlei Problem. Also kommt wohl ein Update für mich vorerst nicht in Frage. Es sein denn, jemand hat für mich eine Lösung parat, wie man das oben beschriebene Problem lösen kann.

Bis mir der rettende Gedanke kommt, werde ich erst einmal sämtliche Plugins unter dem Standardtheme ausprobieren. Eine Auflistung der Plugins, die ich verwende und über deren Kompatibilität erscheinen dann in einem nächsten Beitrag.

Die Autorin:

Sylvi

Meine Beiträge beinhalten eigene Erfahrungen, sei es über Soft- und Hardware, Social Media und die ich als WordPress-Bloggerin und Joomlanerin gesammelt habe. Zudem widme ich mich dem schönen Hobby "Fotografie".

5 Kommentare

Kommentare hinzufügen
  • „Nur was soll mir die Stelle in der index.php nun sagen?“

    Das bedeutet, dass die Schleife nicht richtig beendet wurde. Wahrscheinlich fehlt an dieser Stelle oder in der Zeile davor eine schließende geschweifte Klammer oder ein Strichpunkt.

    Du kannst mir die Datei auch mal per E-Mail schicken, dann gucke ich sie mir an smilie

    • Ja, ich hatte auch versucht den Loop an verschiedenen Stellen zu schließen. Ein anderer Tipp, den ich ergoogelt hatte besagte, dass nach permalinks in der Zeile Permalink der Strichpunkt fehlen könnte. All das habe ich ausprobiert, aber die Fehlermeldung blieb. Kann ich gerne machen Cujo. Ich hatte übrigens auch noch andere Themes von skinpress ausprobiert. Einige stießen die gleiche Fehlermeldung aus. Dazu zählten die Themes: Black Power 1.6, Tree House 1.6 und Wcute 1.6. Die Themes, mit denen ich in der Lokalinstallation keine Probleme hatte waren: Maroon King 1.6, Rainbow 1.0 und saffron spice 1.0.
      Seltsam ist nur, dass ich bei der Testinstallation in einer Subdomain auf dem Server keine Probleme mehr mit dem Theme Smoky hatte.

  • Normalerweise ist es bei php so, dass hinter einem Funktionsaufruf ein Strichpunkt stehen muss. In diesem Fall kann er aber weg gelassen werden, weil es die einzige Anweisung ist und dahinter kein weiterer PHP-Befehl bzw. Funktionsaufruf folgt. Deshalb hast du auch keinen Unterschied bemerkt, als du den Strichpunkt eingefügt hast.

    • Ich hätte nicht gedacht, dass ich mich doch mal mit php im Detail befassen muss. Bei Joomla musste ich das bisher auch kaum, bei WordPress wird man als Blogbetreiber immer wieder damit konfrontiert. Aber Gott sei Dank gibt es ja viele informative Blogs, die einem dabei helfen.
      Danke für Deine Info, Cujo. Dann scheint die Datei ja doch in Ordnung zu sein. Falls ich mal wieder Fragen dazu haben sollte, weiß ich ja, an wen ich mich wenden kann smilie

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Wenn Du hier kommentierst, bist Du mit den Datenschutzbedingungen von Sylvis Blog einverstanden.

Du kannst diese HTML-tags und attribute verwenden: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Copyright © Sylvis Blog • 2019. Alle Rechte vorbehalten. •   Impressum   •    Datenschutzerklärung